旁路网关(旁路由)折腾记
浏览 2297 | 评论 0 | 字数 2093
NiNya
2020年07月24日
  •   文章最后更新于:.
      受某些因素影响,本文章可能具有一定的时效性,请以实际情况为准!另外,欢迎留言~

    主路由辣鸡mt7621属实弟中之弟,搞得我带着小猫咪飞越长城,走向世界的步伐都变慢了,想了想,还是整个旁路网关来玩玩吧。

    一、旁路由的相关操作

    因为在物理机上部署 Proxmox 的教程很多,在此就不赘述了,主要是记录下在部署过程中碰到的一些问题。
    第一个问题就是我已经做好系统并且确认虚拟机上旁路由也已经获取到了IP地址,但是打不开旁路由的管理网页。这个我是在 PVE 控制台的命令行界面来解决的,具体过程如下:

    • 键入命令 vi /etc/config/network
    • 把以下内容全部覆盖network文件(注意自己修改相关内容)
    config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
    
    
    config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.x' # 你要分配给旁路由的IP地址
        option gateway '192.168.1.1' # 你的主路由地址
        option netmask '255.255.255.0'
        option ip6assign '60'
        option multipath 'on'
        list dns '192.168.1.1' # 你的主路由地址

    这样设置好之后你应该就能进入旁路由的管理网页了,进入旁路由界面,选择网络→防火墙→基本设置,设置如下图

    然后进入防火墙的自定义规则,在最后一行添加iptables -t nat -I POSTROUTING -j MASQUERADE
    保存并应用,最后重启旁路由设备。

    二、主路由的相关设置

    如果你希望手动指定网关的话就不需要做这么一步了

    1.命令行界面操作方法

    这部分操作请在主路由的 SSH 界面进行。
    依然是键入vi /etc/config/network
    然后修改network文件中lan部分的内容并保存

    config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1' #主路由地址不要修改
        option gateway '192.168.1.x' #旁路由地址
        option dns '192.168.1.x' #旁路由地址

    接着键入vi /etc/config/dhcp
    修改dhcp中的config dhcp 'lan'以下内容并且保存

    config dhcp 'lan'
        option interface 'lan'
        option ignore '1'
        list dns '192.168.1.x' #旁路由地址

    最后重启你的主路由设备。

    2.管理页操作方法

    进入主路由管理页的网络→接口→lan,进行如下操作

    注意,DHCP 服务器下的基本设置中,请选中'忽略此接口'

    然后保存并应用,并重启你的主路由设备。
    重新连接后,你应该可以看到网关和 DHCP 服务器之类的都已经指向旁路网关了。

    三、继续使用 ipv6

    因为我要用 ipv6 挂pt, 所以我还是需要继续保留主路由的DHCPv6 功能的,也就是 DHCPv4 由旁路由承担,而 DHCPv6 依然由主路由承担。

    1.在主路由上的设置

    这一部分请参考我的这篇转载的文章

    2.在旁路由上的设置

    位置在网络→接口→lan→编辑→DHCP 服务器→ipv6 设置

    (感觉只要设置禁用 DHCPv6 服务就行了,但没试,就这样吧,能用就行)

    本文作者:NiNya
    本文链接:https://lilynas.com/archives/656/
    最后修改时间:2020-07-24 15:18:32
    本站未注明转载的文章均为原创,并采用 CC BY-NC-SA 4.0 授权协议,转载请注明来源,谢谢!
    评论
    与本文无关评论请发留言板。请不要水评论,谢谢。
    textsms
    支持 Markdown 语法
    email
    link
    评论列表
    暂无评论