使用中继桥协议实现无线路由器的无缝中继
浏览 1718 | 评论 1 | 字数 2543
NiNya
2021年01月31日
  •   文章最后更新于:.
      受某些因素影响,本文章可能具有一定的时效性,请以实际情况为准!另外,欢迎留言~

    本文转载自:恩山无线论坛,并稍作修改

    使用无线路由器最麻烦的大概就是信号问题了吧,好在现在的无线路由器都已经提供了一键 Mesh 组网功能,使用的是802.11k/v/r 协议,现代 WiFi 6 路由器都已经支持使用Mesh 组网了,但如果我们并没有足够多的支持 Mesh 的路由器时,那我们就必须另辟蹊径了,找一些老办法。


    ↑ 此拓扑图来自恩山的 weereew 大佬

    准备工作

    首先我们需要一台能够刷入 OpenWRT 开源固件的设备,N1盒子啊,普通无线路由器啥的都可以,把它当作二级路由。
    首先,我们要确保我们的固件中已经安装了luci-proto-relayrelayd两个软件,但有一个问题就是网上很多提供的编译好的固件并不预置这两个软件,且使用opkg安装后也不显示中继桥选项,这可能需要你花一点时间自己去寻找自带这两个软件的固件,或者自己编译一个合适的固件(推荐!)。

    操作过程


    登录 OpenWRT 后台管理页,找到“网络”→“无线”选项卡,点击扫描,然后在接下来的对话框中的WPA 密钥键入自己主路由的密码,创建/分配防火墙区域选择lan,点击保存&应用,稍等一会就能看到二级路由已经连接上了主路由。
    之后,使用 Xshell 或者 Putty 等软件使用 SSH 方式连接我们的路由器,键入命令vi /etc/config/network,编辑以下内容:

    config interface 'loopback'
                     option ifname 'lo'
                     option proto 'static'
                     option ipaddr '127.0.0.1'
                     option netmask '255.0.0.0'
    
    config interface 'lan'
              option ifname 'eth0'
                     option type 'bridge'
                     option proto 'static'
                     option netmask '255.255.255.0'
                     option ipaddr '192.168.1.30'   #手动指派二级路由ip地址,必须与主路由保持同网段
                     option dns '223.5.5.5'  #手动指定 DNS
                     
    # 添加中继桥
    config interface 'stabridge'
                     option proto 'relay'
                     option network 'lan wwan'
    
    config interface 'wwan'
              option proto 'dhcp'
            

    然后,键入vi /etc/config/dhcp,修改以下内容

    config dhcp lan
            option interface        lan
            option start         100
            option limit        150
            option leasetime        12h
            option ignore 1          #添加这个参数,关掉lan的dhcp功能

    最后,键入vi /etc/config/firewall,修改以下内容

    config zone
            option name 'lan'
            option input 'ACCEPT'
            option output 'ACCEPT'
            option forward 'ACCEPT'       #修改为ACCEPT
            option network 'lan wwan'     #添加了wwan

    然后键入reboot重启二级路由,完工!
    这样操作之后,连接二级路由开出的热点,依旧是与主路由保持在同一网段,不用再麻烦做各种穿透了,巴适!

    题外话


    突然发现现在新编译的OpenWRT固件已经能够在软件层面支持802.11k/v/r 协议,下次试试 OpenWRT 路由器 Mesh 组网能不能成!
    另外,我这里已经编译好了一份能供Newifi3无线路由器使用的自带中继桥协议的固件,如果你用的是新三并且找半天都找不到合适的固件,可以试下我的哟。这个固件我用的是Lienol的源码,固件里只集成了几个内网穿透的软件,比如 Frpc 和 Nps 啥的,当然也是支持 IPv6 的。梯子?梯子在用于中继的路由器上屁用没有!
    下载地址:新三自编译固件

    参考资料:
    恩山无线论坛-weereew

    本文作者:NiNya
    本文链接:https://lilynas.com/archives/658/
    最后修改时间:2021-01-31 17:21:14
    本站未注明转载的文章均为原创,并采用 CC BY-NC-SA 4.0 授权协议,转载请注明来源,谢谢!
    评论
    与本文无关评论请发留言板。请不要水评论,谢谢。
    textsms
    支持 Markdown 语法
    email
    link
    评论列表
    已有 1 条评论
    匿名
    2021-03-27 11:06
    受到启发